Top Ad unit 728 × 90

Dê uma olhada

random

Etherchannel

Vamos falar sobre etherchannel, também conhecido como link aggregation. O etherchannel é uma tecnologia que permite agrupar vários links físicos em um único link lógico. Vamos entender como o etherchannel funciona e quais são as suas vantagens. Podemos começar com o exemplo de uma rede bem simples:


Observe a figura acima. Temos dois switches e dois computadores conectados aos switches. Os computadores estão conectados com interfaces de 1000 Mbps, ao passo que o link entre os switches é de apenas 100 Mbps. Se um dos computadores enviar algum tráfego que exceda os 100 Mbps de largura de banda (bandwidth), haverá congestionamento e o tráfego será descartado.

Existem duas soluções para este problema:

  1. Substituir o link entre os switches por uma largura de banda maior, como um link Gigabit ou 10Gigabit, por exemplo.

  2. Adicionar vários links e agrupá-los em um etherchannel.

Já que estamos falando de etherchannel, vamos dar uma olhada na segunda opção:


Adicionamos alguns links extras à nossa topologia. O problema agora é que temos um cenário em loop, de modo que o STP (Spanning Tree Protocol) bloqueará três dos quatro links, fazendo com que a largura de banda permaneça em 100 Mbps. O etherchannel resolve esse problema criando um único link virtual a partir desses links físicos:


Combinando quatro links de 100 Mbps cada, temos agora um link de 400 Mbps. O STP enxerga os quatro links físicos como um único link lógico, e por isso a topologia fica livre de loops. O etherchannel fará o balanceamento de carga entre os quatro links e ficará responsável por controlar a redundância. Se um dos links falhar, o etherchannel continuará trabalhando em cima dos links restantes.

Há um limite para a quantidade de links que podemos usar: 8 interfaces físicas.

E caso a gente queira configurar o etherchannel, podemos escolher um dos seguintes protocolos:

  • PAgP - proprietário da Cisco.

  • LACP - padrão aberto do IEEE.

Esses protocolos são capazes de criar um etherchannel dinamicamente. Também é possível configurar um etherchannel estaticamente, sem que esses protocolos façam a negociação.

Para criarmos um etherchannel, precisamos ter a certeza de que todas as portas possuem a mesma configuração:

  • O duplex tem que ser o mesmo.

  • O speed tem que ser o mesmo.

  • A VLAN nativa e as VLANs permitidas devem ser as mesmas.

  • O modo deve ser o mesmo (acesso ou trunk).

O PAgP e o LACP verificarão se a configuração das interfaces é a mesma.

Se usarmos o PAgP (Port Aggregation Protocol), temos algumas opções que podemos escolher para a configuração das portas:

  • On: a interface torna-se membro do etherchannel, mas não negocia.

  • Desirable: a interface solicitará ativamente que o outro lado se torne membro do etherchannel.

  • Auto: a interface aguardará passivamente o outro lado pedir para que ela se torne membro do etherchannel.

  • Off: a interface não fará parte do etherchannel.

Vamos analisar um exemplo de como configurar o PAgP entre dois switches. Usaremos SW1 e SW2:


SW1 e SW2 possuem, cada um, duas interfaces FastEthernet, 0/23 e 0/24. Vamos agrupar ambas as interfaces em um único link lógico.

SW1(config)#interface FastEthernet0/23
SW1(config-if)#channel-group 1 mode ?
  active     Enable LACP unconditionally
  auto       Enable PAgP only if a PAgP device is detected
  desirable  Enable PAgP unconditionally
  on         Enable Etherchannel only
  passive    Enable LACP only if a LACP device is detected

Vamos começar pelas interfaces físicas, onde criaremos um channel-group que será identificado pelo número 1. No output acima podemos ver as diversas opções disponíveis para PAgP e LACP.

SW1(config)#interface FastEthernet0/23
SW1(config-if)#channel-group 1 mode desirable
Creating a port-channel interface Port-channel 1

SW1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/23, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/23, changed state to up
SW1(config-if)#
SW1(config-if)#interface FastEthernet0/24
SW1(config-if)#channel-group 1 mode desirable
SW1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to up

Configuramos SW1 no modo PAgP desirable. SW1 solicitará ativamente que SW2 se torne membro do etherchannel.

SW2(config)#interface FastEthernet0/23
SW2(config-if)#channel-group 1 mode auto
Creating a port-channel interface Port-channel 1

SW2(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/23, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/23, changed state to up
SW2(config-if)#
SW2(config-if)#interface FastEthernet0/24
SW2(config-if)#channel-group 1 mode auto
SW2(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to up

SW2 foi configurado no modo PAgP auto e responderá às solicitações para se tornar membro do etherchannel.

SW1 %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
SW2 %LINK-3-UPDOWN: Interface Port-channel1, changed state to up

Os switches mostrarão uma mensagem confirmando a criação de uma interface Port-channel.

SW1(config)#interface Port-channel 1
SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#switchport mode trunk
SW1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/23, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to down
%LINK-3-UPDOWN: Interface Port-channel1, changed state to down
SW1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/23, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to down
SW1(config-if)#
%LINK-3-UPDOWN: Interface Port-channel1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up
SW2(config)#interface Port-channel 1
SW2(config-if)#switchport trunk encapsulation dot1q
SW2(config-if)#switchport mode trunk
SW2(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/23, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to down
%LINK-3-UPDOWN: Interface Port-channel1, changed state to down
SW2(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/23, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to down
SW2(config-if)#
%LINK-3-UPDOWN: Interface Port-channel1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up

São nas interfaces Port-channel de ambos os switches que aplicaremos as configurações que antes estavam associadas ao link de 100 Mbps. Definimos o modo trunk com encapsulamento 802.1Q.

SW1#show etherchannel 1 port-channel
                Port-channels in the group:
                ---------------------------

Port-channel: Po1
------------

Age of the Port-channel   = 0d:00h:27m:46s
Logical slot/port   = 2/1           Number of ports = 2
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse
Protocol            =   PAgP
Port security       = Disabled

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
  0     00     Fa0/23   Desirable-Sl       0
  0     00     Fa0/24   Desirable-Sl       0

Time since last port bundled:    0d:00h:03m:09s    Fa0/23
Time since last port Un-bundled: 0d:00h:03m:15s    Fa0/24

O comando acima é uma das opções para checar a configuração do etherchannel. O output nos informa se o port-channel está ativo ou não. Também podemos confirmar que estamos usando o PAgP. As interfaces FastEthernet 0/23 e 0/24 estão sendo usadas para o etherchannel em modo desirable.

SW1#show etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      N - not in use, no aggregation
        f - failed to allocate aggregator

        M - not in use, minimum links not met
        m - not in use, port not aggregated due to minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port

        A - formed by Auto LAG


Number of channel-groups in use: 1
Number of aggregators:           1

Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         PAgP      Fa0/23(P)    Fa0/24(P)

Se tivéssemos muitos etherchannels, poderíamos usar o comando show etherchannel summary. Ele nos fornece uma visão geral de todos os etherchannels e interfaces que estão em uso.

SW1#show interfaces FastEthernet0/24 etherchannel
Port state    = Up Mstr In-Bndl
Channel group = 1           Mode = Desirable-Sl    Gcchange = 0
Port-channel  = Po1         GC   = 0x00010001      Pseudo port-channel = Po1
Port index    = 0           Load = 0x00            Protocol =   PAgP

Flags:  S - Device is sending Slow hello.  C - Device is in Consistent state.
        A - Device is in Auto mode.        P - Device learns on physical port.
        d - PAgP is down.
Timers: H - Hello timer is running.        Q - Quit timer is running.
        S - Switching timer is running.    I - Interface timer is running.

Local information:
                                Hello    Partner  PAgP     Learning  Group
Port      Flags State   Timers  Interval Count   Priority   Method  Ifindex
Fa0/24    SC    U6/S7   H       30s      1        128        Any      18

Partner's information:

          Partner              Partner          Partner         Partner Group
Port      Name                 Device ID        Port       Age  Flags   Cap.
Fa0/24    SW2                  aabb.cc80.aa00   Fa0/24      23s SAC     10001

Age of the port in the current state: 0d:00h:09m:16s

O terceiro método de verificação do etherchannel é o comando show interfaces etherchannel. No exemplo acima, visualizamos as informações de etherchannel da interface FastEthernet0/24 de SW1. Além das informações do switch local, podemos ver também a interface do switch vizinho (SW2).

Vamos voltar aos modos disponíveis para o PAgP:

  • On
  • Desirable
  • Auto
  • Off

Configuramos SW1 no modo desirable e SW2 no modo auto. No entanto, existem algumas combinações que não funcionam:


A tabela acima nos fornece um resumo das relações entre os modos. "Sim" significa que podemos combinar um modo com o outro; "Não" indica que, se configurarmos um modo em um lado e o outro modo no outro lado, o etherchannel não funcionará.

Lembre-se de que a configuração de uma interface no modo On não gera nenhuma negociação, por isso não é possível usá-lo se o outro lado estiver configurado como auto ou desirable.

Aqui estão os comandos de configuração usados neste texto, caso você queira testar as atividades em laboratório. Tenha em mente que, dependendo da versão de IOS que você esteja usando, alguns comandos podem não estar disponíveis. Além disso, o simulador Packet Tracer, da Cisco, limita os comandos que podem ser inseridos na CLI dos dispositivos.
hostname SW1
!
interface FastEthernet0/23
 channel-group 1 mode desirable 
!
interface FastEthernet0/24
 channel-group 1 mode desirable 
!
interface port-channel 1
 switchport trunk encapsulation dot1q 
 switchport mode trunk
!
end
hostname SW2
!
interface FastEthernet0/23
 channel-group 1 mode auto 
!
interface FastEthernet0/24
 channel-group 1 mode auto
!
interface port-channel 1
 switchport trunk encapsulation dot1q 
 switchport mode trunk
!
end

O LACP (Link Aggregation Control Protocol) é muito semelhante ao PAgP. Com ele também temos algumas opções para a configuração das interfaces:

  • On: a interface torna-se membro do etherchannel, mas não negocia.

  • Active: a interface solicitará ativamente que o outro lado se torne membro do etherchannel.

  • Passive: a interface aguardará passivamente o outro lado pedir para que ela se torne membro do etherchannel.

  • Off: a interface não fará parte do etherchannel.

É basicamente a mesma coisa que o PAgP, mas a terminologia é diferente. Vamos à configuração do LACP:

SW1(config)#default interface FastEthernet0/23
Interface FastEthernet0/23 set to default configuration
SW1(config)#default interface FastEthernet0/24
Interface FastEthernet0/24 set to default configuration
SW1(config)#
%LINK-3-UPDOWN: Interface Port-channel1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to down
SW2(config)#default interface FastEthernet0/23
Interface FastEthernet0/23 set to default configuration
SW2(config)#default interface FastEthernet0/24
Interface FastEthernet0/24 set to default configuration
SW1(config)#no interface Port-channel 1
SW2(config)#no interface Port-channel 1

Os comandos acima limpam a configuração de PAgP nos dois switches.

SW1(config)#interface FastEthernet0/23
SW1(config-if)#channel-group 1 mode active
Creating a port-channel interface Port-channel 1

SW1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/23, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/23, changed state to up
%EC-5-L3DONTBNDL2: Fa0/23 suspended: LACP currently not enabled on the remote port.
SW1(config-if)#
SW1(config)#interface FastEthernet0/24
SW1(config-if)#channel-group 1 mode active
SW1(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to up
%EC-5-L3DONTBNDL2: Fa0/24 suspended: LACP currently not enabled on the remote port.

Configuramos SW1 no modo LACP active.

SW2(config)#interface FastEthernet0/23
SW2(config-if)#channel-group 1 mode passive
Creating a port-channel interface Port-channel 1

SW2(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/23, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/23, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to up
SW2(config-if)#
SW2(config)#interface FastEthernet0/24
SW2(config-if)#channel-group 1 mode passive
SW2(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/24, changed state to up

SW2 foi configurado no modo LACP passive.

SW1#show  etherchannel 1 port-channel
                Port-channels in the group:
                ---------------------------

Port-channel: Po1    (Primary Aggregator)

------------

Age of the Port-channel   = 0d:00h:05m:38s
Logical slot/port   = 2/1           Number of ports = 2
HotStandBy port = null
Port state          = Port-channel Ag-Inuse
Protocol            =   LACP
Port security       = Disabled

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
  0     00     Fa0/23   Active             0
  0     00     Fa0/24   Active             0

Time since last port bundled:    0d:00h:02m:48s    Fa0/24

Podemos novamente usar o comando show etherchannel port-channel para verificar a configuração. O protocolo agora é o LACP, e as interfaces FastEthernet 0/23 e 0/24 estão em modo ativo.

A configuração de PAgP e LACP é quase idêntica. Não se esqueça que o PAgP só pode ser usado entre dispositivos Cisco, diferentemente do LACP, que por ser um padrão aberto pode ser usado com dispositivos de outros fabricantes.


A tabela acima fornece um resumo das combinações possíveis entre os modos do LACP. Nada muda em comparação com o PAgP, exceto os nomes dos modos active e passive, que no PAgP são desirable e auto, respectivamente.

Podemos ver ainda o balanceamento de carga no etherchannel:

SW1#show etherchannel load-balance
EtherChannel Load-Balancing Configuration:
        src-mac

EtherChannel Load-Balancing Addresses Used Per-Protocol:
Non-IP: Source MAC address
  IPv4: Source MAC address
  IPv6: Source MAC address

Usamos o comando show etherchannel load-balance para visualizar a configuração padrão. O output acima mostra que o etherchannel está executando o balanceamento de carga com base nos endereços MAC de origem.

SW1(config)#port-channel load-balance ?
  dst-ip       Dst IP Addr
  dst-mac      Dst Mac Addr
  src-dst-ip   Src XOR Dst IP Addr
  src-dst-mac  Src XOR Dst Mac Addr
  src-ip       Src IP Addr
  src-mac      Src Mac Addr

Podemos usar o comando port-channel load-balance, em modo de configuração global, para alterar a base do balanceamento de carga. O output acima nos mostra que podemos escolher entre endereço MAC/IP de origem/destino ou uma combinação de origem/destino.

Mas por que deveríamos nos preocupar com o balanceamento de carga? Dê uma olhada na topologia abaixo:


Temos quatro computadores e um roteador do lado direito. O mecanismo padrão de balanceamento de carga usa como base o endereço MAC de origem. Isso significa que todo o tráfego de um endereço MAC será enviado por uma única interface física. Por exemplo:

  • O tráfego do endereço MAC AAA usará a interface FastEthernet0/23 de SW1.

  • O tráfego do endereço MAC BBB usará a interface FastEthernet0/24 de SW1.

  • O tráfego do endereço MAC CCC usará a interface FastEthernet0/23 de SW1.

  • O tráfego do endereço MAC DDD usará a interface FastEthernet0/24 de SW1.

Como temos quatro computadores, tudo bem, ambos os links físicos em SW1 serão usados pelo etherchannel, então, dependendo do volume de tráfego que os computadores enviem, o etherchannel estará próximo de uma proporção 1:1.

Mas em SW2 a história é diferente, pois nele temos um roteador com endereço MAC EEE. O etherchannel escolherá uma das interfaces físicas de SW2 (FastEthernet0/23 ou 0/24) para que todo o tráfego do roteador seja enviado por ela. Um dos links físicos nunca será usado para transportar o tráfego do roteador.

SW2(config)#port-channel load-balance dst-mac

Numa situação como essa, vale a pena alterar a base do balanceamento de carga. Se o etherchannel usar o endereço MAC de destino como base em SW2, faremos o balanceamento de carga para o tráfego do roteador entre as duas interfaces físicas. Quando o tráfego do roteador chegar em SW2 com destino aos computadores, o mecanismo de balanceamento de carga do etherchannel analisará o endereço MAC de destino para decidir por qual interface enviar o tráfego. Os frames destinados aos endereços MAC AAA e CCC serão enviados pela interface FastEthernet0/23, e os frames destinados a BBB e DDD serão enviados pela FastEthernet0/24.

Aqui estão os comandos de configuração usados neste texto, caso você queira testar as atividades em laboratório. Tenha em mente que, dependendo da versão de IOS que você esteja usando, alguns comandos podem não estar disponíveis. Além disso, o simulador Packet Tracer, da Cisco, limita os comandos que podem ser inseridos na CLI dos dispositivos.
hostname SW1
!
interface FastEthernet0/23
 channel-group 1 mode active 
!
interface FastEthernet0/24
 channel-group 1 mode active
!
interface port-channel 1
 switchport trunk encapsulation dot1q 
 switchport mode trunk
!
end
hostname SW2
!
interface FastEthernet0/23
 channel-group 1 mode passive
!
interface FastEthernet0/24
 channel-group 1 mode passive
!
interface port-channel 1
 switchport trunk encapsulation dot1q 
 switchport mode trunk
!
port-channel load-balance dst-mac
!
end

Isso é tudo o que temos a falar sobre etherchannel por enquanto.

Hope this helps!

Etherchannel Reviewed by Carlos Wolkartt on dezembro 30, 2018 Rating: 5
Todos os direitos reservados a Wolkartt.com © 2019
Hospedado no Blogger.

Mande sua mensagem

Nome

E-mail *

Mensagem *

Tecnologia do Blogger.