Top Ad unit 728 × 90

Dê uma olhada

random

Configuração de links trunk no Cisco IOS

Os links trunk são necessários para transportar tráfego de VLAN entre um switch e outro. Neste texto, vamos entender como configurar um link trunk entre switches Cisco Catalyst. Usaremos a seguinte topologia:


Temos um computador conectado a cada switch. Colocaremos os dois computadores na mesma VLAN e configuraremos um link trunk entre os dois switches.

Vamos começar criando a VLAN:

SW1(config)#vlan 20
SW1(config-vlan)#name Computadores
SW1(config-vlan)#exit
SW1(config)#vlan 20
SW2(config-vlan)#name Computadores
SW2(config-vlan)#exit

E vamos colocar as interfaces conectadas aos computadores na VLAN que criamos:

SW1(config)#interface FastEthernet0/1
SW1(config-if)#switchport access vlan 20
SW2(config)#interface FastEthernet0/1
SW2(config-if)#switchport access vlan 20

Agora podemos criar o link trunk entre os dois switches. Tecnicamente, neste instante as interfaces entre os dois switches devem estar em modo de acesso, pois ambas estão numa única VLAN.

SW1(config)#interface FastEthernet0/24
SW1(config-if)#switchport mode trunk
Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode.
SW2(config)#interface FastEthernet0/24
SW2(config-if)#switchport mode trunk
Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode.

Tentamos mudar as interfaces para o modo trunk com o comando switchport mode trunk. Dependendo do modelo do switch, podemos nos deparar com o erro acima. Se quisermos mudar a interface para o modo trunk, precisamos mudar o tipo de encapsulamento do trunk. Vamos dar uma olhada nas opções disponíveis:

SW1(config)#interface FastEthernet0/24
SW1(config-if)#switchport trunk encapsulation ?
  dot1q      Interface uses only 802.1q trunking encapsulation when trunking
  isl        Interface uses only ISL trunking encapsulation when trunking
  negotiate  Device will negotiate trunking encapsulation with peer on interface

Podemos escolher entre o encapsulamento 802.1Q ou ISL. Por padrão, o switch em questão negociará o tipo de encapsulamento do trunk.

SW1(config-if)#switchport trunk encapsulation dot1q
SW2(config-if)#switchport trunk encapsulation dot1q

Alteramos o encapsulamento para 802.1Q usando o comando switchport trunk encapsulation.

SW1#show interfaces FastEthernet0/24 switchport
Name: Fa0/24
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
<output restante omitido>
SW2#show interfaces FastEthernet0/24 switchport
Name: Fa0/24
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
<output restante omitido>

Podemos ver que agora o encapsulamento do trunk é o 802.1Q.

SW1(config)#interface FastEthernet0/24
SW1(config-if)#switchport mode trunk
SW2(config)#interface FastEthernet0/24
SW2(config-if)#switchport mode trunk

Depois disso, conseguimos alterar com sucesso o modo da interface para trunk.

SW1#show interfaces FastEthernet0/24 switchport
Name: Fa0/24
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
<output restante omitido>
SW2#show interfaces FastEthernet0/24 switchport
Name: Fa0/24
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
<output restante omitido>

Podemos confirmar que o link trunk foi estabelecido porque o modo operacional é o "dot1q".

Vamos tentar pingar entre PC1 e PC2:

C:\Users\PC1>ping 192.168.1.2

Disparando 192.168.1.2 com 32 bytes de dados:
Resposta de 192.168.1.2: bytes=32 tempo<1ms TTL=128
Resposta de 192.168.1.2: bytes=32 tempo<1ms TTL=128
Resposta de 192.168.1.2: bytes=32 tempo<1ms TTL=128
Resposta de 192.168.1.2: bytes=32 tempo<1ms TTL=128

Estatísticas do Ping para 192.168.1.2:
    Pacotes: Enviados = 4, Recebidos = 4, Perdidos = 0 (0% de
             perda),
Aproximar um número redondo de vezes em milissegundos:
    Mínimo = 0ms, Máximo = 0ms, Média = 0ms

Excelente! PC1 e PC2 podem alcançar um ao outro. Isso significa que terminamos por aqui? Ainda não... Vamos dar uma olhada em algumas outras coisas:

SW2#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/5
                                                Fa0/6, Fa0/7, Fa0/8, Fa0/9
                                                Fa0/10, Fa0/11, Fa0/12, Fa0/13
                                                Fa0/14, Fa0/15, Fa0/16, Fa0/17
                                                Fa0/18, Fa0/19, Fa0/20, Fa0/21
                                                Fa0/22, Fa0/23
                                                Gi0/1, Gi0/2
20   Computadores                     active    Fa0/1

Em primeiro lugar, não encontramos a interface FastEthernet0/24 no output do comando show vlan. Isso é completamente normal porque o comando show vlan mostra apenas as interfaces que estão em modo de acesso.

SW2#show interfaces FastEthernet0/24 trunk

Port        Mode             Encapsulation  Status        Native vlan
Fa0/24      on               802.1q         trunking      1

Port        Vlans allowed on trunk
Fa0/24      1-4094

Port        Vlans allowed and active in management domain
Fa0/24      1,20

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/24      1,20

Com o comando show interfaces trunk podemos ver se uma interface está em modo trunk, qual protocolo de encapsulamento está sendo usado (802.1Q ou ISL) e qual é a VLAN nativa do trunk. Também podemos ver que as VLANs de 1 a 4094 são permitidas no trunk.

Observe que atualmente apenas a VLAN 1 (nativa) e a VLAN 20 estão ativas. Por fim, mas não menos importante, conseguimos ver quais VLANs estão no estado forwarding para o spanning-tree.

Antes de continuarmos, vamos dar uma olhada em outro detalhe:

SW2#show interfaces FastEthernet0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: static access

Uma interface pode estar em modo de acesso ou em modo trunk. A interface acima está conectada ao PC2 e o seu modo operacional é "static access", o que significa que a interface está em modo de acesso.

SW2#show interfaces FastEthernet0/24 switchport
Name: Fa0/24
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk

Podemos ver que a interface FastEthernet0/24 está em modo operacional "trunk". Essa é a interface de SW2 que se conecta a SW1. 

SW2(config)#interface FastEthernet0/24
SW2(config-if)#switchport mode ?
  access        Set trunking mode to ACCESS unconditionally
  dot1q-tunnel  set trunking mode to TUNNEL unconditionally
  dynamic       Set trunking mode to dynamically negotiate access or trunk mode
  private-vlan  Set private-vlan mode
  trunk         Set trunking mode to TRUNK unconditionally

Se tentarmos alterar o modo de uma interface, poderemos ver algumas opções além de acesso e trunk. Existe o método dinâmico. Não vamos nos preocupar com as outras opções por enquanto.

SW2(config-if)#switchport mode dynamic ?
  auto       Set trunking mode dynamic negotiation parameter to AUTO
  desirable  Set trunking mode dynamic negotiation parameter to DESIRABLE

Podemos escolher entre dynamic auto e dynamic desirable. O switch descobrirá automaticamente se a interface deve ficar em modo de acesso ou em modo trunk. Mas qual é a diferença entre o auto e o desirable? Vamos descobrir.


Vamos brincar com o comando switchport mode em SW1 e SW2 e observar os resultados.

SW1(config)#interface FastEthernet0/24
SW1(config-if)#switchport mode dynamic auto
SW2(config)#interface FastEthernet0/24
SW2(config-if)#switchport mode dynamic auto

Alteramos as duas interfaces para dynamic auto.

SW1#show interfaces FastEthernet0/24 switchport
Name: Fa0/24
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
<output restante omitido>
SW2#show interfaces FastEthernet0/24 switchport
Name: Fa0/24
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
<output restante omitido>

O modo administrativo ficou como dynamic auto e agora temos uma porta de acesso.

SW1(config)#interface FastEthernet0/24
SW1(config-if)#switchport mode dynamic desirable
SW2(config)#interface FastEthernet0/24
SW2(config-if)#switchport mode dynamic desirable
SW1#show interfaces FastEthernet0/24 switchport
Name: Fa0/24
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
<output restante omitido>
SW2#show interfaces FastEthernet0/24 switchport
Name: Fa0/24
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
<output restante omitido>

Depois de alterarmos as duas interfaces para dynamic desirable, terminamos com um link trunk.

O que deve acontecer se os dois modos forem misturados? Dynamic auto em um lado e dynamic desirable no outro... Vamos ver:

SW1(config)#interface FastEthernet0/24
SW1(config-if)#switchport mode dynamic desirable
SW2(config)#interface FastEthernet0/24
SW2(config-if)#switchport mode dynamic auto
SW1#show interfaces FastEthernet0/24 switchport
Name: Fa0/24
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
<output restante omitido>
SW2#show interfaces FastEthernet0/24 switchport
Name: Fa0/24
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
<output restante omitido>

Os switches estão mesmo dispostos a estabelecer um link trunk... Vamos ver o que acontece com outras combinações:

SW1(config)#interface FastEthernet0/24
SW1(config-if)#switchport mode dynamic auto
SW2(config)#interface FastEthernet0/24
SW2(config-if)#switchport mode trunk
SW1#show interfaces FastEthernet0/24 switchport
Name: Fa0/24
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
<output restante omitido>
SW2#show interfaces FastEthernet0/24 switchport
Name: Fa0/24
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
<output restante omitido>

O dynamic auto preferirá deixar a interface em modo de acesso, mas se a outra interface estiver configurada em modo trunk, terminaremos com um link trunk.

SW1(config)#interface FastEthernet0/24
SW1(config-if)#switchport mode dynamic auto
SW2(config)#interface FastEthernet0/24
SW2(config-if)#switchport mode access
SW1#show interfaces FastEthernet0/24 switchport
Name: Fa0/24
Switchport: Enabled
Administrative Mode: dynamic auto
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
<output restante omitido>
SW2#show interfaces FastEthernet0/24 switchport
Name: Fa0/24
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
<output restante omitido>

Configurando um lado como dynamic auto e o outro como acesso, o resultado será uma interface de acesso.

SW1(config)#interface FastEthernet0/24
SW1(config-if)#switchport mode dynamic desirable
SW2(config)#interface FastEthernet0/24
SW2(config-if)#switchport mode trunk
SW1#show interfaces FastEthernet0/24 switchport
Name: Fa0/24
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
<output restante omitido>
SW2#show interfaces FastEthernet0/24 switchport
Name: Fa0/24
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
<output restante omitido>

A combinação de dynamic desirable e trunk nos oferece um link trunk. 

E o que vai acontecer se configurarmos uma interface em modo de acesso e a outra em modo trunk? Não parece ser uma boa ideia, mas vamos dar uma olhada:

SW1(config)#interface FastEthernet0/24
SW1(config-if)#switchport mode access
SW2(config)#interface FastEthernet0/24
SW2(config-if)#switchport mode trunk
SW1#show interfaces FastEthernet0/24 switchport
Name: Fa0/24
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
<output restante omitido>
SW2#show interfaces FastEthernet0/24 switchport
Name: Fa0/24
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
<output restante omitido>
SW1#
%SPANTREE-7-RECV_1Q_NON_TRUNK: Received 802.1Q BPDU on non trunk FastEthernet0/24 VLAN1.
%SPANTREE-7-BLOCK_PORT_TYPE: Blocking FastEthernet0/24 on VLAN0001. Inconsistent port type.
%SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/24 on VLAN0001. Port consistency restored.

Assim que alteramos o modo das interfaces, vimos as mensagens de erro do spanning-tree em SW1. O spanning-tree é um protocolo executado em switches para impedir loops de camada 2.

A tabela abaixo resume os resultados das combinações entre os diferentes modos:


Aqui estão os comandos de configuração usados neste texto, caso você queira testar as atividades em laboratório. Tenha em mente que, dependendo da versão de IOS que você esteja usando, alguns comandos podem não estar disponíveis. Além disso, o simulador Packet Tracer, da Cisco, limita os comandos que podem ser inseridos na CLI dos dispositivos.
hostname SW1
!
vlan 20
 name Computadores
!
interface FastEthernet0/1
 switchport access vlan 20
!
interface FastEthernet0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
end
hostname SW2
!
vlan 20
 name Computadores
!
interface FastEthernet0/1
 switchport access vlan 20
!
interface FastEthernet0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
end

Hope this helps!

Configuração de links trunk no Cisco IOS Reviewed by Carlos Wolkartt on janeiro 09, 2019 Rating: 5
Todos os direitos reservados a Wolkartt.com © 2019
Hospedado no Blogger.

Mande sua mensagem

Nome

E-mail *

Mensagem *

Tecnologia do Blogger.